$re = '/today ((?:jack|joe|and| )*)john(?1)\bgo to the beach/';
$str = 'today john jack and joe go to the beach
today joe and john go to the beach
today jack and joe go to the beach';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);