import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Description\\s*?:\\s(?P<description>.*)";
final String string = "Description: package change history notification tool\n"
+ " The tool apt-listchanges can compare a new version of a\n"
+ " package with the one currently installed and show what has been\n"
+ " changed, by extracting the relevant entries from the Debian changelog\n"
+ " and NEWS files.\n"
+ " .\n"
+ " It can be run on several .deb archives at a time to get a list of all\n"
+ " changes that would be caused by installing or upgrading a group of\n"
+ " packages. When configured as an APT plugin it will do this\n"
+ " automatically during upgrades.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}