// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Description\s*?:\s(?P<description>.*)").unwrap();
let string = "Description: package change history notification tool
The tool apt-listchanges can compare a new version of a
package with the one currently installed and show what has been
changed, by extracting the relevant entries from the Debian changelog
and NEWS files.
.
It can be run on several .deb archives at a time to get a list of all
changes that would be caused by installing or upgrading a group of
packages. When configured as an APT plugin it will do this
automatically during upgrades.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}