import re
regex = re.compile(r"Description\s*?:\s(?P<description>.*)", flags=re.MULTILINE)
test_str = ("Description: package change history notification tool\n"
" The tool apt-listchanges can compare a new version of a\n"
" package with the one currently installed and show what has been\n"
" changed, by extracting the relevant entries from the Debian changelog\n"
" and NEWS files.\n"
" .\n"
" It can be run on several .deb archives at a time to get a list of all\n"
" changes that would be caused by installing or upgrading a group of\n"
" packages. When configured as an APT plugin it will do this\n"
" automatically during upgrades.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")