re = /Description\s*?:\s(?P<description>.*)/m
str = 'Description: package change history notification tool
The tool apt-listchanges can compare a new version of a
package with the one currently installed and show what has been
changed, by extracting the relevant entries from the Debian changelog
and NEWS files.
.
It can be run on several .deb archives at a time to get a list of all
changes that would be caused by installing or upgrading a group of
packages. When configured as an APT plugin it will do this
automatically during upgrades.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end