#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)((?:(?!((\sincoming|outgoing)\smessage)).)*keyword.*?)((incoming|outgoing)\smessage)"
Local $sString = "Incoming message Incoming message Incoming message keyword abctext keyword Incoming message Incoming message gsgsfvhvhgh gfvgvhhhjjbn 765568856866" & @CRLF & _
"" & @CRLF & _
"Incoming message outgoing message Incoming message 91981966802866 keyword other text Dhai 20-12-2017 15:29:47 Text Incoming message"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")