import re
regex = re.compile(r"((?:(?!((\sincoming|outgoing)\smessage)).)*keyword.*?)((incoming|outgoing)\smessage)", flags=re.IGNORECASE)
test_str = ("Incoming message Incoming message Incoming message keyword abctext keyword Incoming message Incoming message gsgsfvhvhgh gfvgvhhhjjbn 765568856866\n\n"
"Incoming message outgoing message Incoming message 91981966802866 keyword other text Dhai 20-12-2017 15:29:47 Text Incoming message")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")