re = /((?:(?!((\sincoming|outgoing)\smessage)).)*keyword.*?)((incoming|outgoing)\smessage)/i
str = 'Incoming message Incoming message Incoming message keyword abctext keyword Incoming message Incoming message gsgsfvhvhgh gfvgvhhhjjbn 765568856866
Incoming message outgoing message Incoming message 91981966802866 keyword other text Dhai 20-12-2017 15:29:47 Text Incoming message'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end