import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:(?!((\\sincoming|outgoing)\\smessage)).)*keyword.*?)((incoming|outgoing)\\smessage)";
final String string = "Incoming message Incoming message Incoming message keyword abctext keyword Incoming message Incoming message gsgsfvhvhgh gfvgvhhhjjbn 765568856866\n\n"
+ "Incoming message outgoing message Incoming message 91981966802866 keyword other text Dhai 20-12-2017 15:29:47 Text Incoming message";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}