#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)L_\d\d?_"
Local $sString = "L_1_3" & @CRLF & _
"L_2_23" & @CRLF & _
"L_3_91" & @CRLF & _
"L_3_16"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)