$re = '/L_\d\d?_/m';
$str = 'L_1_3
L_2_23
L_3_91
L_3_16';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;