package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\p{L}\p{N}-_'.@]+|"\w+"`)
var str = `higgs-boson
fred's kitchen
2001
@dragonflyeye.net
Ulyssus'
"af"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}