import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\p{L}\\p{N}-_'.@]+|\"\\w+\"";
final String string = "higgs-boson\n"
+ "fred's kitchen\n"
+ "2001\n"
+ "@dragonflyeye.net\n"
+ "Ulyssus'\n"
+ "\"af\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}