$re = '/[\p{L}\p{N}-_\'.@]+|"\w+"/m';
$str = 'higgs-boson
fred\'s kitchen
2001
@dragonflyeye.net
Ulyssus\'
"af"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);