const regex = /^(?'MSGTYPE'[A-Z]{3})\n(?'FLIGHTNO'[A-Z0-9]{3,})\/(?'DATE'[0-9]{2})\.(?'ACREG'[A-Z0-9]{5,}).(?'ORIGIN'[A-Z]{3})\n(?'MVTTYPE'[A-Z]{2})(?'PUSH'[0-9]{4,6})\/(?'TAKEOFF'[0-9]{4,6}) (?'ETA'[A-Z]{2}[0-9]{4}) (?'DESTINATION'[A-Z]{3})\n(?'SI1'.{0,})\n(?'SI2'.{0,})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?\'MSGTYPE\'[A-Z]{3})\\n(?\'FLIGHTNO\'[A-Z0-9]{3,})\\\/(?\'DATE\'[0-9]{2})\\.(?\'ACREG\'[A-Z0-9]{5,}).(?\'ORIGIN\'[A-Z]{3})\\n(?\'MVTTYPE\'[A-Z]{2})(?\'PUSH\'[0-9]{4,6})\\\/(?\'TAKEOFF\'[0-9]{4,6}) (?\'ETA\'[A-Z]{2}[0-9]{4}) (?\'DESTINATION\'[A-Z]{3})\\n(?\'SI1\'.{0,})\\n(?\'SI2\'.{0,})$', '')
const str = `MVT
XX1203/07.HELLO.AMS
AD1402/1413 EA1524 SVG
PX??
SI MAP1405`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}