import re
regex = re.compile(r"^(?'MSGTYPE'[A-Z]{3})\n(?'FLIGHTNO'[A-Z0-9]{3,})\/(?'DATE'[0-9]{2})\.(?'ACREG'[A-Z0-9]{5,}).(?'ORIGIN'[A-Z]{3})\n(?'MVTTYPE'[A-Z]{2})(?'PUSH'[0-9]{4,6})\/(?'TAKEOFF'[0-9]{4,6}) (?'ETA'[A-Z]{2}[0-9]{4}) (?'DESTINATION'[A-Z]{3})\n(?'SI1'.{0,})\n(?'SI2'.{0,})$")
test_str = ("MVT\n"
"XX1203/07.HELLO.AMS\n"
"AD1402/1413 EA1524 SVG\n"
"PX??\n"
"SI MAP1405")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")