use strict;
my $str = 'MVT
XX1203/07.HELLO.AMS
AD1402/1413 EA1524 SVG
PX??
SI MAP1405';
my $regex = qr/^(?'MSGTYPE'[A-Z]{3})\n(?'FLIGHTNO'[A-Z0-9]{3,})\/(?'DATE'[0-9]{2})\.(?'ACREG'[A-Z0-9]{5,}).(?'ORIGIN'[A-Z]{3})\n(?'MVTTYPE'[A-Z]{2})(?'PUSH'[0-9]{4,6})\/(?'TAKEOFF'[0-9]{4,6}) (?'ETA'[A-Z]{2}[0-9]{4}) (?'DESTINATION'[A-Z]{3})\n(?'SI1'.{0,})\n(?'SI2'.{0,})$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}