$re = '/^(?\'MSGTYPE\'[A-Z]{3})\n(?\'FLIGHTNO\'[A-Z0-9]{3,})\/(?\'DATE\'[0-9]{2})\.(?\'ACREG\'[A-Z0-9]{5,}).(?\'ORIGIN\'[A-Z]{3})\n(?\'MVTTYPE\'[A-Z]{2})(?\'PUSH\'[0-9]{4,6})\/(?\'TAKEOFF\'[0-9]{4,6}) (?\'ETA\'[A-Z]{2}[0-9]{4}) (?\'DESTINATION\'[A-Z]{3})\n(?\'SI1\'.{0,})\n(?\'SI2\'.{0,})$/';
$str = 'MVT
XX1203/07.HELLO.AMS
AD1402/1413 EA1524 SVG
PX??
SI MAP1405';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);