using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"dat\D*?wy\D*(\d{1,4}([\/ .-])\d{1,2}\2\d{1,4})";
string input = @"abc18.Dat wy.03/12/2019FFF*Dato dost2009/03/03**data wy2020-09-30";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}