const regex = new RegExp('dat\\D*?wy\\D*(\\d{1,4}([\\/ .-])\\d{1,2}\\2\\d{1,4})', 'gmi')
const str = `abc18.Dat wy.03/12/2019FFF*Dato dost2009/03/03**data wy2020-09-30`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}