import re
regex = re.compile(r"dat\D*?wy\D*(\d{1,4}([\/ .-])\d{1,2}\2\d{1,4})", flags=re.MULTILINE | re.IGNORECASE)
test_str = "abc18.Dat wy.03/12/2019FFF*Dato dost2009/03/03**data wy2020-09-30"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")