import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "dat\\D*?wy\\D*(\\d{1,4}([\\/ .-])\\d{1,2}\\2\\d{1,4})";
final String string = "abc18.Dat wy.03/12/2019FFF*Dato dost2009/03/03**data wy2020-09-30";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}