# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^>\s+(\S+(?:\s\S+)*)/<blockquote><h3>Quote<\/h3><p>$1<\/p><\/blockquote>/gm;t' <<< "> this is a quote that
runs
for multiple
lines
but you need the pattern to stop matching when the quote
is finished. Perhaps force your pattern to stop matching when it encounters 2 consecutive whitespace characters.
> Quote before a double space!
The ^ in the pattern says that that quotes will only be recognized if the > is at the start of the a line. e.g. This > is not a quote, it is being used as a greater sign.
> End with a quote"