// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^>\s+(\S+(?:\s\S+)*)").unwrap();
let string = "> this is a quote that
runs
for multiple
lines
but you need the pattern to stop matching when the quote
is finished. Perhaps force your pattern to stop matching when it encounters 2 consecutive whitespace characters.
> Quote before a double space!
The ^ in the pattern says that that quotes will only be recognized if the > is at the start of the a line. e.g. This > is not a quote, it is being used as a greater sign.
> End with a quote";
let substitution = "<blockquote><h3>Quote</h3><p>$1</p></blockquote>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}