import Foundation
let pattern = #"^>\s+(\S+(?:\s\S+)*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
> this is a quote that
runs
for multiple
lines
but you need the pattern to stop matching when the quote
is finished. Perhaps force your pattern to stop matching when it encounters 2 consecutive whitespace characters.
> Quote before a double space!
The ^ in the pattern says that that quotes will only be recognized if the > is at the start of the a line. e.g. This > is not a quote, it is being used as a greater sign.
> End with a quote
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<blockquote><h3>Quote</h3><p>$1</p></blockquote>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)