import re
regex = re.compile(r"^>\s+(\S+(?:\s\S+)*)", flags=re.MULTILINE)
test_str = ("> this is a quote that\n"
"runs\n"
"for multiple\n"
"lines\n\n"
"but you need the pattern to stop matching when the quote\n"
"is finished. Perhaps force your pattern to stop matching when it encounters 2 consecutive whitespace characters.\n\n"
"> Quote before a double space!\n\n"
"The ^ in the pattern says that that quotes will only be recognized if the > is at the start of the a line. e.g. This > is not a quote, it is being used as a greater sign.\n\n"
"> End with a quote")
subst = "<blockquote><h3>Quote</h3><p>$1</p></blockquote>"
result = regex.sub(subst, test_str)
if result:
print(result)