import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<title\\>)(.*?)(?=(,|\\s*<\\/title>))";
final String string = "<title>Kincrome K1500G - Tool Workshop Contour 472 Piece 15 Drawer 1/4\", 3/8\" & 1/2\" Drive Monster Green</title>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}