const regex = /(?<=<title\>)(.*?)(?=(,|\s*<\/title>))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=<title\\>)(.*?)(?=(,|\\s*<\\\/title>))', 'gm')
const str = `<title>Kincrome K1500G - Tool Workshop Contour 472 Piece 15 Drawer 1/4", 3/8" & 1/2" Drive Monster Green</title>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}