re = /(?<=<title\>)(.*?)(?=(,|\s*<\/title>))/m
str = '<title>Kincrome K1500G - Tool Workshop Contour 472 Piece 15 Drawer 1/4", 3/8" & 1/2" Drive Monster Green</title>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end