$re = '/\bfeature\.?\w+(?!(ONLY|PRACA))\b/m';
$str = 'feature.Agencyjna_ONLY
feature.UoP
feature.UoD
feature.PRACA
featurePRACA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);