const regex = /(?s)^(?!.*\[\d+]$)(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)^(?!.*\\[\\d+]$)(.*)', 'gm')
const str = `Dee, DP(Dee, D. P.)[1];Uppala, SM(Uppala, S. M.)[0];Simmons, AJ(Simmons, A. J.)[0];Kobayashi, S(Kobayashi, S.)[2];Andrae, U(Andrae, U.)`;
const subst = `\1[0]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);