$re = '/(?s)^(?!.*\[\d+]$)(.*)/m';
$str = 'Dee, DP(Dee, D. P.)[1];Uppala, SM(Uppala, S. M.)[0];Simmons, AJ(Simmons, A. J.)[0];Kobayashi, S(Kobayashi, S.)[2];Andrae, U(Andrae, U.)';
$subst = "\1[0]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;