use strict;
my $str = 'Dee, DP(Dee, D. P.)[1];Uppala, SM(Uppala, S. M.)[0];Simmons, AJ(Simmons, A. J.)[0];Kobayashi, S(Kobayashi, S.)[2];Andrae, U(Andrae, U.)';
my $regex = qr/(?s)^(?!.*\[\d+]$)(.*)/mp;
my $subst = '\\1[0]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";