using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(a[^abcd][^bcd]*|[^abcd]{2}[^bcd]*a[^bcd]*)$";
string input = @"aeghjk
qwerty
aeaaasf
qberty
qasdfg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}