re = /^(a[^abcd][^bcd]*|[^abcd]{2}[^bcd]*a[^bcd]*)$/m
str = 'aeghjk
qwerty
aeaaasf
qberty
qasdfg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end