package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(a[^abcd][^bcd]*|[^abcd]{2}[^bcd]*a[^bcd]*)$`)
var str = `aeghjk
qwerty
aeaaasf
qberty
qasdfg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}