$re = '/^(a[^abcd][^bcd]*|[^abcd]{2}[^bcd]*a[^bcd]*)$/m';
$str = 'aeghjk
qwerty
aeaaasf
qberty
qasdfg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);