#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(abc.?\s*(\b\s*\w+\s*\b){0,7}\s*\bsome\s*name\b)"
Local $sString = "abc/ef 12,345 some name" & @CRLF & _
"abc/ef 12.345 some name" & @CRLF & _
"abc/ef 12345 some name"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")