re = /(abc.?\s*(\b\s*\w+\s*\b){0,7}\s*\bsome\s*name\b)/mi
str = 'abc/ef 12,345 some name
abc/ef 12.345 some name
abc/ef 12345 some name'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end