// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(abc.?\s*(\b\s*\w+\s*\b){0,7}\s*\bsome\s*name\b)").unwrap();
let string = "abc/ef 12,345 some name
abc/ef 12.345 some name
abc/ef 12345 some name";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}