using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(abc.?\s*(\b\s*\w+\s*\b){0,7}\s*\bsome\s*name\b)";
string input = @"abc/ef 12,345 some name
abc/ef 12.345 some name
abc/ef 12345 some name";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}