# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^.*?keyword|\G(?!^))[^\[\]]+\K[\[\]]//gm;t' <<< "ab[ cd] [][asfg] ]] ef keyword [ gh ] ij "