import re
regex = re.compile(r"(?:^.*?keyword|\G(?!^))[^\[\]]+\K[\[\]]", flags=re.MULTILINE)
test_str = "ab[ cd] [][asfg] ]] ef keyword [ gh ] ij "
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)