$re = '/(?:^.*?keyword|\G(?!^))[^\[\]]+\K[\[\]]/m';
$str = 'ab[ cd] [][asfg] ]] ef keyword [ gh ] ij ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;