use strict;
my $str = 'ab[ cd] [][asfg] ]] ef keyword [ gh ] ij ';
my $regex = qr/(?:^.*?keyword|\G(?!^))[^\[\]]+\K[\[\]]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";