#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^1(?!(?:this|is|a|demo)2$).*2$"
Local $sString = "1this2" & @CRLF & _
"1is2" & @CRLF & _
"1a2" & @CRLF & _
"1demo2" & @CRLF & _
"" & @CRLF & _
" # want match" & @CRLF & _
"1demoo2" & @CRLF & _
"1demo12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")