re = /^1(?!(?:this|is|a|demo)2$).*2$/m
str = '1this2
1is2
1a2
1demo2
# want match
1demoo2
1demo12'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end