import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^1(?!(?:this|is|a|demo)2$).*2$";
final String string = "1this2\n"
+ "1is2\n"
+ "1a2\n"
+ "1demo2\n\n"
+ " # want match\n"
+ "1demoo2\n"
+ "1demo12";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}