using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^1(?!(?:this|is|a|demo)2$).*2$";
string input = @"1this2
1is2
1a2
1demo2
# want match
1demoo2
1demo12";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}