using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ftp:\/\/[\w-_.\/]+";
string input = @"ftp://10.5.0.22/go/to/dir
ftp://name? /root
ftp://name/root";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}